No Output After DITA-OT Publish


Condition

When users execute a DITA-OT publish on a DITA asset collection, the system doesn't generate output files in the CMS pub folder.

Troubleshooting No Output After DITA Publish
Troubleshooting No Output After DITA Publish

Cause

A spectrum of issues can prevent the DITA-OT transformation process from generating output files. These issues can vary depending on factors involved. Keep in mind that these steps provide general guidelines and direction for pinpointing and resolving a wide range of issues that may cause the output generation to fail.

Output Issue Diagnosis

System administrators and users.
Identify the issue that causes the output generation failure.

To diagnose the issue:

  1. Double-check your DITA publishing setup.
    Ensure the appropriate settings were in place when the system executed the DITA publish.

    See the DITA Publishing Pipeline Troubleshoot Checklist to double check your DITA administration settings and DITA publishing settings.

  2. Run debug mode to include debugging details in the next DITA publish log.

    See Running DITA Debug Mode for details.

  3. Apply the same DITA publishing settings used when you encountered the missing output, and check the DITA log for errors.

    These errors may provide details about where the conflict resides and what the conflict entails.

  4. Check the CMS publishing log for errors and to review the asset files included within the DITA publish post processing.
  5. Ensure the DITA output folder resides in the appropriate location within the CMS site directory.
    See Checking DITA Publishing Output Directory for details.
    Note
    If the DITA logs indicate the DITA-OT transformation process failed in the Has Errors column, then skip this step.
  6. Review the DITA temp folder for discrepancies within the temporary files that may relate to the issue.
  7. If you discover errors within the logs, interpret them to determine what the conflicts entail.

Address Output Issues

System administrators and users.

Use the information you gathered from troubleshooting to resolve output issues.

The following list provides potential solutions to address your issue. Keep in mind that you may uncover alternative solutions not provided in this list.