DITA Publish Log Entries Flag Errors
Condition
When users execute a DITA-OT publish on a DITA asset collection, the system generates DITA publish log entry errors.
In some scenarios, the DITA logs contain errors but the Has Errors column doesn't flag those errors in the Post Processing Status Console dialog within the Logs tab.
Cause
A spectrum of issues can cause the DITA-OT transformation process to generate DITA publish log entry errors. These issues can vary depending on factors involved. Keep in mind that these steps provide general guidelines and direction for pinpointing and resolving a wide range of issues that may cause DITA log entry errors.
Error Issue Diagnosis
To diagnose the issue:
Address Error Issues
Use the information you gathered from troubleshooting to resolve DITA log entry errors.
The following list provides potential solutions to address your issue. Keep in mind that you may uncover alternative solutions not provided in this list.
- If your issue relates to the DITA publishing setup, then adjust your setup settings as needed.
- If your issue relates to a dependency error, where you can resolve the issue by restoring a missing file or by modifying the dependency reference in your DITA asset content, then apply fixes to the affected DITA assets as needed.
- If your issue relates to a DITA specification validation error, where you can resolve the issue by making changes to your DITA asset content, then check out the affected DITA assets and apply fixes as needed.
- If your issue relates
to DITA-OT output formats, where you can resolve the issue by changing
the output format, then do one of the following:
- Choose another output format provided by the standard DITA-OT that resolves the issue.
- Provide your own custom output format plugin that resolves the issue.
- If your issue relates to DITA-OT parameters, where you can resolve the issue by changing parameter settings, then modify parameters for the CMS DITA-OT as needed.
- If your issue
relates to the DITA-OT version, then do one of the following:
- Install a different DITA-OT version that better suits your organization's needs than the currently installed version.
- Install a custom DITA-OT engine that suits your organization's needs.
- If your issue is an unresolved DITA-OT bug, report the issue via GitHub: DITA-OT Issues.
- If your issue relates to something else, or if the solutions above do not suffice, then contact Ingeniux Support.
After implementing your solution, republish the DITA asset collection, and then review the DITA logs to see if the output DITA logs contain errors. If you still encounter issues, try another solution, or contact Ingeniux Support.