DITA Publish Log Entries Flag Errors


Condition

When users execute a DITA-OT publish on a DITA asset collection, the system generates DITA publish log entry errors.

In some scenarios, the DITA logs contain errors but the Has Errors column doesn't flag those errors in the Post Processing Status Console dialog within the Logs tab.

Troubleshooting DITA Publish Errors
Troubleshooting DITA Publish Errors

Cause

A spectrum of issues can cause the DITA-OT transformation process to generate DITA publish log entry errors. These issues can vary depending on factors involved. Keep in mind that these steps provide general guidelines and direction for pinpointing and resolving a wide range of issues that may cause DITA log entry errors.

Important
The Has Errors column only indicates conflicts when the DITA-OT transformation process encounters a fatal error that halts the entire process. If the Has Errors column indicates no conflicts, the log may still contain errors and warnings that did not halt the DITA-OT process.

Error Issue Diagnosis

Administrators can double-check the DITA publishing pipeline setup and run debug mode. Users with asset editing and publishing permissions can execute DITA publishes, and review log and temp entries.
Identify the issue that causes the DITA publish log errors.

To diagnose the issue:

  1. Double-check your DITA publishing setup.
    Ensure the appropriate settings were in place when the system executed the DITA publish.

    See the DITA Publishing Pipeline Troubleshoot Checklist to double check your DITA administration settings and DITA publishing settings.

  2. Run debug mode to include debugging details in the next DITA publish log.

    See Running DITA Debug Mode for details.

  3. Check the DITA log to see if you run into the same previously experienced errors.

    These errors may provide details about where the conflict resides and what the conflict entails.

  4. Check the CMS publishing log for errors and to review the asset files included within the DITA publish post processing.
  5. Check the DITA output directory to review the output file results within the CMS site directory.
    See Checking DITA Publishing Output Directory for details.
    Note
    If the DITA logs indicate the DITA-OT transformation process failed in the Has Errors column, then skip this step.
  6. Review the DITA temp folder for discrepancies within the temporary files that may relate to the issue.
  7. Interpret the log entry errors to determine what the conflicts entail.

Address Error Issues

Administrators can modify the DITA publishing pipeline setup and settings related to the DITA-OT. Users with asset editing permissions can resolve conflicts with DITA asset content and their dependencies, and they can modify settings applied at DITA publish time.

Use the information you gathered from troubleshooting to resolve DITA log entry errors.

The following list provides potential solutions to address your issue. Keep in mind that you may uncover alternative solutions not provided in this list.

After implementing your solution, republish the DITA asset collection, and then review the DITA logs to see if the output DITA logs contain errors. If you still encounter issues, try another solution, or contact Ingeniux Support.