Condition
When users execute CMS publishes, the Configure DITA Publishing
dialog does not display. This issue prevents users from executing DITA-OT publishes on their
DITA asset collections.
Cause
For the Configure DITA Publishing dialog to display, the system
requires administrators to complete the DITA Administration setup and the DITA
post-publish content processor setup.
Note
The
Configure DITA Publishing dialog does not display for
site-wide publishes. Site-wide publishes use the settings. See
DITA Output Management Properties for details.
Remedy Part 1: Double-Check DITA Publishing Pipeline Setup
Administrators- Ensure your settings are configured.
- Ensure all DITA asset collections reside under the DITA root folder in .
- Ensure your DITA post-publish processing settings are configured for the
appropriate publishing targets.
See Configuring Post-Publish Content Processor for details.
Important
Ensure that the DITA processor includes the normalized DITA
output format, and ensure the normalized DITA output format has a partial match
string in place for rendering the normalized DITA on the DSS.
- Provide asset publishing permissions to users who will execute DITA publishes. See
Creating Groups for details to provide users with
permissions.
Remedy Part 2: Display the DITA Publish Dialog
Users- Navigate to .
- Check in and mark for publish all assets included within your DITA collection. Mark
them for the publishing target associated with the DITA post-publish content
processor.
- Select the DITA map or topic in the Assets Tree.
Note
The CMS always executes DITA publishes from a DITA map, regardless
of if you choose a DITA topic for publish.
- Execute the CMS publish on the DITA asset. Ensure that you publish to the
publishing target with the DITA processor.