No DITA Preview Output Generates in the DITA Preview or XML Tabs


Condition

The preview output for DITA assets does not generate and display in the Content screen of the DITA Preview and or the XML tabs.

Cause

Errors display in the Content screen but the Log screen does not indicate issues with the transformation output.

Remedy

Administrators can double-check the DITA publishing pipeline setup. Users with asset editing permissions can execute DITA preview, view the results, and review log and temp entries.
  1. Double-check your DITA publishing setup.
    Ensure the appropriate settings were in place when the system executed the DITA publish.

    See the DITA Publishing Pipeline Troubleshoot Checklist to double check your DITA administration settings and DITA publishing settings.

    Important
    Check these settings in particular:
    • Ensure all Normalization Output Format settings are configured. Ensure the Rendering Schema for DSS field references the correct page schema. See Configuring DITA Open Toolkit Output Formats for details.
    • Ensure the DITA processor includes the normalized DITA output format, and ensure the normalized DITA output format has a partial match string in place for rendering the normalized DITA on the DSS.

  2. If the errors indicate issues with your DSS Preview, the DSS Preview solution may require updates. Contact Ingeniux Support.
  3. If the preview map scope has an existing cached preview, the preview cache may be outdated. See Clearing DITA Preview Cache for details to delete the preview cache.
  4. Run the DITA-OT preview transformation process again. If the errors persist, contact Ingeniux Support.

Cause

No views are associated with the DITA page schema used for DSS content rendering.

Remedy

Administrators can double-check the DITA publishing pipeline setup. Users with asset editing permissions can execute DITA preview, view the results, and review log and temp entries.
  1. Double-check your DITA publishing setup.
    Ensure the appropriate settings were in place when the system executed the DITA publish.

    See the DITA Publishing Pipeline Troubleshoot Checklist to double check your DITA administration settings and DITA publishing settings.

    Important
    Check these settings in particular:
    • Ensure all Normalization Output Format settings are configured. Ensure the Rendering Schema for DSS field references the correct page schema. the See Configuring DITA Open Toolkit Output Formats for details.
    • Ensure the DITA processor includes the normalized DITA output format, and ensure the normalized DITA output format has a partial match string in place for rendering the normalized DITA on the DSS.

  2. Associate views with the page schema you selected for the Rendering Schema for DSS field. Ensure the views have the appropriate configurations and reside within the appropriate location. See Setting up DSS with ASP.Net Views to Display Content for details.
  3. If the preview map scope has an existing cached preview, the preview cache may be outdated. See Clearing DITA Preview Cache for details to clear the preview cache.
  4. Run the DITA-OT preview transformation process again. If the errors persist, contact Ingeniux Support.

Cause

Fatal errors display in the DITA-OT logs via the Log screen that prevented the preview output from generating.

Remedy

Users with asset editing permissions can execute DITA preview, view the results, and review log and temp entries. See DITA Preview Log Entries Flag Errors for details to troubleshoot DITA-OT log errors.