Users Cannot Access DITA Publish Dialog


Condition

When users execute CMS publishes, the Configure DITA Publishing dialog does not display. This issue prevents users from executing DITA-OT publishes on their DITA asset collections.

Cause

For the Configure DITA Publishing dialog to display, the system requires administrators to complete the DITA Administration setup and the DITA post-publish content processor setup.

Remedy Part 1: Double-Check DITA Publishing Pipeline Setup

Administrators
  1. Ensure your Administration > DITA settings are configured.

    See DITA Administration for details.

    Important
    Ensure all Normalization Output Format settings are configured. See Configuring DITA Open Toolkit Output Formats for details.
  2. Ensure all DITA asset collections reside under the DITA root folder in Assets > Assets Tree.
    See Defining DITA Root Folder for details about the DITA root folder.
  3. Ensure your DITA post-publish processing settings are configured for the appropriate publishing targets.

    See Configuring Post-Publish Content Processor for details.

    Important
    Ensure that the DITA processor includes the normalized DITA output format, and ensure the normalized DITA output format has a partial match string in place for rendering the normalized DITA on the DSS.
  4. Provide asset publishing permissions to users who will execute DITA publishes. See Creating Groups for details to provide users with permissions.

Remedy Part 2: Display the DITA Publish Dialog

Users
  1. Navigate to Assets > Assets Tree.
  2. Check in and mark for publish all assets included within your DITA collection. Mark them for the publishing target associated with the DITA post-publish content processor.
  3. Select the DITA map or topic in the Assets Tree.
    Note
    The CMS always executes DITA publishes from a DITA map, regardless of if you choose a DITA topic for publish.
  4. Execute the CMS publish on the DITA asset. Ensure that you publish to the publishing target with the DITA processor.
    The Publish dialog closes, and the Configure DITA Publishing dialog displays.

    See Publishing DITA Assets for details to run DITA publishes.

    Configuring DITA Publish Dialog

    Troubleshooting
    If the Configure DITA Publishing dialog still does not display, then contact contact Ingeniux Support.